Obamacare Site Vulnerable to Heartbleed Bug

As if there hasn't already been enough security red flags with the Obamacare website, there's now another very serious one: heartbleed.  Yes, the major security vulnerbility affects the Obamacare website, and is the latest black eye for the botched and failed health care law.  Heartbleed, which has affected many websites, allows hackers to intercept and steal sensitive information.  And what's more sensitive than all of your private health care information?

Register to read more...

Additional information

Copyright © 2021 Habledash, Inc. All Rights Reserved.
Habledash. Unabashed Politics. No Apologies.